Issue #110 31 May 2018
Written by: Bas Broek
With WWDC around the corner (it starts in four days!), it is not that big of a surprise that these last two weeks have been pretty quiet when it comes to Swift.
Also, come and say hi at WWDC!
In episode 59, Jesse and JP discuss implicit escaping of closures, explaining in how they (should) work.
In episode 60, Jesse and JP discuss Character Properties, a proposal pitch that aims to increase the usefulness of
Character and approachability of programming in Swift.
News and community
Commits and pull requests
Proposals in review
This proposal renames the confusing and misnamed
KeyValueList. This type is neither a dictionary nor a literal. It is a list of key-value pairs.
There is no strong motivation to deprecate. The type does not produce active harm. Instead, it adds measurable (if small) utility and will be part of the ABI. A sensible renaming mitigates the most problematic issue with the type.
SE-0202, as accepted, introduces a type,
Random, as the default source of random numbers on each platform.
[..] the name
Randomfor this default source is misleading, and would probably be better named
One open question is the naming of the getter for an instance of the type. Currently it is
Random.default. However, renaming
Randomleads to the rather clunky
DefaultRandomNumberGenerator.default. Benjamin suggests
.shared. However, in all current implementations, this is not strictly speaking a shared instance – it is instead a getter/setter for a fresh instance each time. This doesn’t actually have a cost, since the type has no actual size (the type is just a vehicle for calling an OS function), but needs to be done this way because
Any suggestions for better naming gratefully received.